You are here:GeoTux»Geo-Foros»PROBLEMAS CON LA INSTALACION DE PMAPPER

Estadísticas

Invitados: 50
Usuarios registrados: 3093
Usuarios en línea:
-
Registrados hoy:
-

Registro

Redifusión (RSS)

Blogs y Noticias:
Recibe las actualizaciones en Geo-Noticias y Geo-Blogs

Recibir por e-mail
Recibir Geo-Noticias y Geo-Blogs por e-mail

¿Qué es esto?

Welcome, Guest
Username Password: Remember me

PROBLEMAS CON LA INSTALACION DE PMAPPER
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: PROBLEMAS CON LA INSTALACION DE PMAPPER

PROBLEMAS CON LA INSTALACION DE PMAPPER 06 May 2014 23:57 #1130

  • jaime86
  • OFFLINE
  • Visitante casual
  • Posts: 5
  • Karma: 0
Hola amigos mi nombre es Jaime... por favor ayudenme con lo siguiente me salen estos errores cuando quiero abrir el mapa por defecto de pmapper...

Warning: ms_newMapObj(): [MapServer Error]: loadOutputFormat(): OUTPUTFORMAT clause references driver GD/JPEG, but this driver isn't configured. in C:\ms4w\apps\pmapper\pmapper-4.0.0\incphp\globals.php on line 60

Warning: ms_newMapObj(): [MapServer Error]: msOutputFormatValidate(): OUTPUTFORMAT png has IMAGEMODE RGB/RGBA, which is not supported for GD drivers. in C:\ms4w\apps\pmapper\pmapper-4.0.0\incphp\globals.php on line 60

Fatal error: Uncaught exception 'MapScriptException' with message 'Failed to open map file "C:/ms4w/apps/pmapper/pmapper-4.0.0/config/default/pmapper_demo.map"' in C:\ms4w\apps\pmapper\pmapper-4.0.0\incphp\globals.php:60 Stack trace: #0 C:\ms4w\apps\pmapper\pmapper-4.0.0\incphp\globals.php(60): ms_newMapObj('C:/ms4w/apps/pm...') #1 C:\ms4w\apps\pmapper\pmapper-4.0.0\map.phtml(37): require_once('C:\ms4w\apps\pm...') #2 {main} thrown in C:\ms4w\apps\pmapper\pmapper-4.0.0\incphp\globals.php on line 60

No se por que me sale eso.. si he seguido todos los pasos correspondientes en la instalación del pmapper.. Que debo configurar internamente..

Re: PROBLEMAS CON LA INSTALACION DE PMAPPER 27 Jun 2014 04:32 #1144

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
Estimado, esperando que hayas resuelto tu problema, puedes indicar la solucion?

Re: PROBLEMAS CON LA INSTALACION DE PMAPPER 11 Jul 2014 06:38 #1147

Hola Jaime, para ayudarte tendrías que versión de ms4w estás utilizando y copiarnos el código del OUTPUTFORMAT de tu fichero map. Dependiendo de si utilizas Mapserver 5 o 6 la configuración de los OUTPUTFORMAT varía en el fichero map:

mapserver.org/mapfile/outputformat.html

Échale un ojo a la guia de migración de Mapserver y busca los OUTPUTFORMAT:

mapserver.org/MIGRATION_GUIDE.html

También sería útil saber que drivers están instalados en tu versión de ms4w, para ello escribe "localhost" en el navegador y en la pantalla que te sale de información de MS4W haz click en el hipervínculo azul "phpinfo" que está dentro de Features, el cual te cargará una nueva página y allí busca la palabra "MapScript" para encontrar la tabla con la información de la versión de mapserver instalada. La mía muestra esto:

MapServer version 5.6.6 OUTPUT=GIF OUTPUT=PNG OUTPUT=JPEG OUTPUT=WBMP OUTPUT=PDF OUTPUT=SWF OUTPUT=SVG SUPPORTS=PROJ SUPPORTS=AGG SUPPORTS=FREETYPE SUPPORTS=ICONV SUPPORTS=FRIBIDI SUPPORTS=WMS_SERVER SUPPORTS=WMS_CLIENT SUPPORTS=WFS_SERVER SUPPORTS=WFS_CLIENT SUPPORTS=WCS_SERVER SUPPORTS=SOS_SERVER SUPPORTS=FASTCGI SUPPORTS=THREADS SUPPORTS=GEOS SUPPORTS=RGBA_PNG SUPPORTS=TILECACHE INPUT=JPEG INPUT=POSTGIS INPUT=OGR INPUT=GDAL INPUT=SHAPEFILE

Y se vé que soporta el driver "AGG" por ejemplo y muchas otras cosas.
  • Page:
  • 1
Time to create page: 0.39 seconds
 

¿Dónde nos leen?

Usuario aleatorio

Últimos comentarios