You are here:GeoTux»Geo-Foros»Warning searchitem pmapper 4.2

Estadísticas

Invitados: 45
Usuarios registrados: 3184
Usuarios en línea:
-
Registrados hoy:
-

Registro

Redifusión (RSS)

Blogs y Noticias:
Recibe las actualizaciones en Geo-Noticias y Geo-Blogs

Recibir por e-mail
Recibir Geo-Noticias y Geo-Blogs por e-mail

¿Qué es esto?

Welcome, Guest
Username Password: Remember me

Warning searchitem pmapper 4.2
(1 viewing) (1) Guest
  • Page:
  • 1
  • 2

TOPIC: Warning searchitem pmapper 4.2

Warning searchitem pmapper 4.2 28 Dic 2012 15:43 #853

  • sandreli
  • OFFLINE
  • Visitante casual
  • Posts: 4
  • Karma: 0
Hola amig@s del foro, mi nombre es Sandro, estoy trabajando con pmapper, Postgres/PostGIS.
He estado insertando unos puntos a mi base de datos, y he querido realizar unas búsquedas utilizando el searchitem del archivo "config_default.xml".

Instalé PEAR con los demás paquetes, quedando de la sgte. manera:

INSTALLED PACKAGES, CHANNEL PEAR.PHP.NET:
=========================================
PACKAGE VERSION STATE
Archive_Tar 1.3.3 stable
Console_Getopt 1.2.3 stable
MDB2 2.4.1 stable
OLE 1.0.0RC1 beta
PEAR 1.9.0 stable
Spreadsheet_Excel_Writer 0.9.3 beta
Structures_Graph 1.0.2 stable
XML_Util 1.2.1 stable

Al hacer la consulta me sale el sgte error.

<b>Warning</b>: require_once(MDB2.php): failed to open stream: No such file or directory in <b>C:\ms4w\Apache\htdocs\sig\incphp\query\suggest.php</b> on line <b>148</b><br />



Muchas gracias desde ya, espero alguien me poueda dar una mano.
Ah!, alguien sabe si es un plugin de pmapper que se activa para poder tener unas "TAB" de capas/leyenda.
Como vi en este: gis.uazuay.edu.ec/visorAtlas/azuay.phtml

Saludos cordiales

Re: Warning searchitem pmapper 4.2 02 Ene 2013 20:17 #857

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
Hola sandreli,

me puedes indicar si instalaste el mdb2_driver_pgsql?? (ademas de mdb2)


respecto a tabs para capas y leyenda, te recomiendo usar alguno de los ejemplos que pmapper tiene en la version para desarrolladores (pmapper-dev)

pmapper llama al archivo map_default.phtml para iniciar la visualizacion. algo que puedes hacer es descargar estos ejemplos y pegarlos en las rutas correspondientes, entonces puedes llamar a cada uno de estos archivos por url (localhost/mapa/map_algo.phtml?config=algo), o bien, reemplazas cada uno de estos por el map_default.phtml y corriges lo que necesitas.


espero haber sido de ayuda, saludos

Re: Warning searchitem pmapper 4.2 03 Ene 2013 16:04 #858

  • sandreli
  • OFFLINE
  • Visitante casual
  • Posts: 4
  • Karma: 0
Muchas gracias pñor responder amigo M3rcury,
efectivamente me faltabna instalar mdb2_Driver_pgsql

Ahoara quedó instlado de la sgte manera:

INSTALLED PACKAGES, CHANNEL PEAR.PHP.NET:
=========================================
PACKAGE VERSION STATE
Archive_Tar 1.3.3 stable
Console_Getopt 1.2.3 stable
MDB2 2.4.1 stable
mdb2_Driver_pgsql 1.4.1 stable
OLE 1.0.0RC1 beta
PEAR 1.9.0 stable
Spreadsheet_Excel_Writer 0.9.3 beta
Structures_Graph 1.0.2 stable
XML_Util 1.2.1 stable

Pero sabes que ahora al hacer la consulta no me muestra nada.
Mi archivo "config_default.xml" lo tengo así:
======================================
<searchlist version="1.0">
<dataroot>$</dataroot>
<searchitem name="Puntos" description="PUNTOS INTERES">
<layer type="postgis" name="Puntos">
<field type="s" name="nombre" description="Busqueda...?" wildcard="0">
<definition type="suggest" connectiontype="db" sort="asc" firstoption="*">
<mslayer encoding="UTF-8" keyfield="nombre" showfield="nombre"/>
</definition>
</field>
</layer>
</searchitem>

</searchlist>
============================================
El "pmapper_demo.map"

####################################
# Capa Puntos
####################################
LAYER
NAME Puntos
TYPE POINT
STATUS OFF
CONNECTION "user=usuario password=password host=localhost dbname=quellongeo"
CONNECTIONTYPE postgis
DATA "the_geom FROM puntos_interes"
TEMPLATE void

PROJECTION
"+proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs no_defs"
END
METADATA
"DESCRIPTION" "Puntos de Interes"
"RESULT_FIELDS" "nombre, direccion, telefono, email"
"RESULT_HEADERS" "NOMBRE, DIRECCION, TELEFONO, E-MAIL"
"ows_title" "Puntos T"
"LAYER_ENCODING" "UTF-8"
END
CLASS
Name 'Puntos'
SYMBOL 'im_punto'
SIZE 20
COLOR 0 170 255
OUTLINECOLOR 0 0 0
END # Class
END # Fin Layer Puntos
============================================
Qué puede ser que ahora al darle un aletra no me suguiere nada, carga, pero no me muestra nada,
muchas gracias amigo por tu tiempo.

Veré los ejemplos que me dices

Re: Warning searchitem pmapper 4.2 04 Ene 2013 00:58 #861

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
Estimado, para descartar cualquier problema... partamos por lo basico
corregire tu capa minimamente, y luego puedes cargarle extras. los comentarios estan escritos en lugar de los parametros

LAYER
NAME "capa_puntos"
TYPE POINT
CONNECTIONTYPE POSTGIS
CONNECTION "user=usuario_bd password=la_de_tu_usuario dbname=nombre_bd host=localhost_o_ip"
DATA "the_geom from (select * from tabla_espacial) AS foo USING UNIQUE gid_o_keytabla USING SRID=4326_u_otra"
STATUS OFF
TEMPLATE void
PROJECTION
"init=epsg:4326"
#"+proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs no_defs"
END
METADATA
"LAYER_ENCODING" "UTF-8"
"DESCRIPTION" "Puntos de Interes"
"RESULT_HEADERS" "NOMBRE,DIRECCION,TELEFONO,EMAIL"
"RESULT_FIELDS" "nombre,direccion,telefono,email"
"OWS_TITLE" 'capa_puntos'
END
CLASS
NAME "Puntos"
SYMBOL "im_punto" #recomiendo eliminar esta linea hasta comprobar que funciona la capa anteponiendo #
SIZE 20
COLOR 0 170 255
OUTLINECOLOR 0 0 0
END
END


...ya debiese funcionar la capa, de lo que me parece que nada mas te faltaban algunos parametros en DATA.
Respecto a la consulta para esta capa debieses usar lo siguiente:


<searchitem name="nombre_search" description="Puntos de Interes">
<layer type="postgis" name="capa_puntos">
<field type="s" name="nombre" description="Nombre" wildcard="2">
<definition type="suggest" connectiontype="db" sort="asc" minlength="1">
<dsn encoding="UTF-8">pgsql://usuario_bd:pswd_detu_usuario@localhost/nombre_bd</dsn>
<sql>SELECT DISTINCT nombre FROM tabla_espacial WHERE nombre ~* '^[search]' ORDER BY nombre</sql>
</definition>
</field>
</layer>
</searchitem>



Espero haber sido de ayuda, saludos

Re: Warning searchitem pmapper 4.2 04 Ene 2013 15:09 #862

  • sandreli
  • OFFLINE
  • Visitante casual
  • Posts: 4
  • Karma: 0
Muchas gracias M3rcury, quedó perfecto...
Saludos


Sandreli

Re: Warning searchitem pmapper 4.2 04 Ene 2013 17:31 #863

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
De nada man, puedes pasar por caja... ajjaja



Saludos

Re: Warning searchitem pmapper 4.2 25 Mar 2013 22:42 #920

  • DannyLeon
  • OFFLINE
  • Visitante casual
  • Posts: 10
  • Karma: 0
m3rcury wrote:
De nada man, puedes pasar por caja... ajjaja

Saludos



Hola Compañeros, desarrollo mi proyecto de grado con estas herramientas y tengo el problemilla este de las consultas a postgis, me podrían indicar por favor como se instala PEAR y sus paquetes adicionales MDB2 y MDB_driver_pgsql... desde ya muchas gracias.

Re: Warning searchitem pmapper 4.2 28 Mar 2013 15:38 #924

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
Estimado, disculpa la demora. Espero te sirva


pear.php.net/manual/en/installation.getting.php


En pocas palabras,
1) bajate el *.phar
2) alojar en directorio de php.ini
3) ejecutar comandos para instalar PEAR
4) ejecutar comandos para librerias extras de PEAR

Saludos y bienvenido!!!
Last Edit: 28 Mar 2013 15:51 by m3rcury. Reason: correccion en la despedida

Re: Warning searchitem pmapper 4.2 28 Mar 2013 19:59 #930

  • DannyLeon
  • OFFLINE
  • Visitante casual
  • Posts: 10
  • Karma: 0
Gracias por responder, compañero tengo instalado php mediante el paquete MS4W el cual viene con el servidor Apache, en la carpeta de apache viene una carpeta llamada php, he pegado hay el archivo *.phar pero no ha funcionado bien,al ejecutar el comando php go-pear.phar me dice que el comando php no se reconoce como interno ni externo ni ejecutable por lotes... no se en que estoy fallando... :/ agradezco mucho la colaboración.

Danny León

Re: Warning searchitem pmapper 4.2 01 Abr 2013 17:09 #934

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
Estimado,

erraste en el ruta que debes alojar el *.phar

Es en el directorio de php.ini y otros.

En una instalacion por defecto es en C:\ms4w\Apache\cgi-bin


Saludos
The following user(s) said Thank You: DannyLeon

Re: Warning searchitem pmapper 4.2 01 Abr 2013 20:03 #936

  • DannyLeon
  • OFFLINE
  • Visitante casual
  • Posts: 10
  • Karma: 0
Amigo muchas gracias, he logrado instalar los paquetes indicados, pear mdb2 y mdb2_driver_pgsql, sin embargo no me sale nada al hacer las consultas...

no se que pueda ser, espero no sea mucho atrevimiento pero dejo mi archivo .map y el config de la consulta...

LAYER
NAME 'Mpio_WGS84'
TYPE POLYGON
DUMP true
TEMPLATE void
EXTENT -90.926980 -5.494431 -54.686684 13.890937
CONNECTIONTYPE postgis
CONNECTION "dbname='Prueba' host=localhost port=5432 user='postgres' password='080509bb'"
DATA 'the_geom FROM "bdqgis"."Mpio_WGS84" USING UNIQUE gid USING srid=4326'
METADATA
'ows_title' 'Mpio_WGS84'
"RESULT_FIELDS" "NOMBRE_MPI,NOMBRE_DPT"
"RESULT_HEADERS" "Municipio,Departamento"
"LAYER_ENCODING" "UTF-8"
END
STATUS OFF
TRANSPARENCY 100
PROJECTION
'proj=longlat'
'datum=WGS84'
'no_defs'
END
CLASS
NAME 'Mpio_WGS84'
STYLE
WIDTH 0.56
OUTLINECOLOR 146 146 146
COLOR 246 245 235
END
END
END
__________________________________________

<searchitem name="Municipio" description="Municipio">
<layer type="postgis" name="Mpio_WGS84">
<field type="s" name="NOMBRE_MPI" description="Municipio" wildcard="1">
<definition type="suggest" connectiontype="db" sort="asc" minlength="1">
<dsn encoding="UTF-8">pgsql://postgres:080509bb@localhost/Prueba</dsn>
</definition>
</field>
</layer>
</searchitem>


agradezco mucho si hay posibilidad de colaborarme con este tema...

Danny León

Re: Warning searchitem pmapper 4.2 02 Abr 2013 14:08 #937

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
Hola Danny,

favor guíate por la sugerencia que hice mas arriba en este hilo con fecha 3 de enero.

Comenta lo que tengas demás con el caracter # al inicio de cada línea (o lo borras), luego corrige las comillas que pueden estar dando problemas también.
Guía la consulta como indiqué en la misma respuesta y seguro te funcionará como le sucedió a sandreli.


Favor coméntanos cómo te va.

Saludos
The following user(s) said Thank You: DannyLeon
  • Page:
  • 1
  • 2
Time to create page: 0.64 seconds
 

¿Dónde nos leen?

Usuario aleatorio

Últimos comentarios