You are here:GeoTux»Geo-Foros»Type "options" no hace nada?? en search de pmapper

Estadísticas

Invitados: 109
Usuarios registrados: 3232
Usuarios en línea:
-
Registrados hoy:
-

Registro

Redifusión (RSS)

Blogs y Noticias:
Recibe las actualizaciones en Geo-Noticias y Geo-Blogs

Recibir por e-mail
Recibir Geo-Noticias y Geo-Blogs por e-mail

¿Qué es esto?

Welcome, Guest
Username Password: Remember me

Type "options" no hace nada?? en search de pmapper
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: Type "options" no hace nada?? en search de pmapper

Type "options" no hace nada?? en search de pmapper 17 Feb 2009 11:00 #158

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
Hola a tod@s!!

es mi primer post y ya toy pidiendo ayuda

estoy intentando hacer una consulta de tipo "options" en el search de pmapper y no se por que al seleccionarlo este simplemente no hace nada (ni siquiera se queda cargando)

modifique un ejemplo que aparece en la lista de usuarios de pmapper y aun no se que pasa

<searchitem name="rutas_options_pg" description="Caminos">
<layer type="postgis" name="Rutas">
<field type="s" name="rutas" description="Seleccione..." wildcard="2">
<definition type="options" connectiontype="db" sort="asc" firstoption="*">
<dsn encoding="UTF-8">pgsql://postgres:postgres@localhost/demogis</dsn>
<sql>SELECT DISTINCT ruta,ruta FROM demociudad WHERE ruta IS NOT NULL ORDER BY ruta</sql>
<dblayer encoding="ISO-8859-1" keyfield="ruta" showfield="ruta"/>
</definition>
</field>
</layer>
</searchitem>

si alguien me pudiera ayudar estaria muy agradecido

Re: Type "options" no hace nada?? en search de pmapper 18 Feb 2009 23:06 #164

  • khalima
  • OFFLINE
  • Entusiasta
  • Posts: 24
  • Karma: 1
Hola

Prueba haciendo algunas modificaciones al XML, segun este codigo, este fue el unico que me funciono, me cuentas como te fue.

<searchitem name="Departamento" description="Departamento">
<layer type="postgis" name="departamento">
<field type="s" name="nombre del campo" description="Departamento" wildcard="0">
<definition type="suggest" connectiontype="ms" sort="asc" firstoption="*">
<mslayer encoding="UTF-8" keyfield="nom_dpto" showfield="dpto"/>
</definition>
</field>
</layer>
</searchitem>

Re: Type "options" no hace nada?? en search de pmapper 19 Feb 2009 10:19 #168

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
hola khalima gracias por responder

probe el codigo que me dijiste, haciendo las modificaciones para mi caso y claro funciona sin problemas como otros "suggest_pg" que tengo en el search.xml

ahora, lo que necesito y quiero lograr es que no tenga que ingresar o llenar un campo, sino que se despliegue una lista con las opciones a seleccionar (listbox/combobox)

el tipo "operator" hace algo como lo que necesito, salvo que aparece un listbox mas un campo a llenar y no me sirve para este caso... necesito que solo muestre un listbox para seleccionar una opcion y la liste en un "result" y visualice en el mapa.

por eso creo que el tipo "options" es la solucion.
desde ya muchas gracias


PD: he modificado los ejemplos con "options_pg" y "options_suggest_pg" que aparecen en pmapper-dev tampoco me funcionan

Re: Type "options" no hace nada?? en search de pmapper 16 Jun 2011 17:30 #595

  • sheopusda
  • OFFLINE
  • Entusiasta
  • Posts: 15
  • Karma: 0
Saludos amig@s.

A mi el suggest, si me funciona todo bien, pero yo tambin necesito desplegar en el (combo box) los datos de la tabla de postgis..

Si a alguien ya le salio, ayuden por favor

********** ASI TENGO EN EL XML, PERO NO SALE NADA DE NADA..!! ************
<searchitem name="Cafeterias" description="CAFETERIAS">
<layer type="postgis" name="Cafeterias">
<field type="s" name="nombre" description="GID" wildcard="2">
<definition type="options" connectiontype="ms" sort="asc" firstoption="*">
<mslayer encoding="UTF-8" keyfield="gid" showfield="nombre"/>
</definition>
</field>
</layer>
</searchitem>

Re: Type "options" no hace nada?? en search de pmapper 16 Jun 2011 17:32 #596

  • sheopusda
  • OFFLINE
  • Entusiasta
  • Posts: 15
  • Karma: 0
DE PRONTO SERA POR LA VERSION DE PMAPPER..????

HELP PLEASE....!!!!!!!!

Re: Type "options" no hace nada?? en search de pmapper 16 Jun 2011 21:30 #597

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
estimado, que versiones de mapserver tienes? ms4w? etc

tienes instalada las librerias pear? y las de mdb2, ole y spreadsheet...?

Re: Type "options" no hace nada?? en search de pmapper 17 Jun 2011 00:10 #600

  • sheopusda
  • OFFLINE
  • Entusiasta
  • Posts: 15
  • Karma: 0
Hola que tal, gracias por la respuesta, pues bien te cuento que la version que tengo instalada de MS4W es la 3.0.1..

Y de las librerias pear y las otras no se muy bien de que se trata. Como puedo saber si estan instalas..?, la verdad soy nuevo en esto y no tengo mucho conocimiento al respecto..

Gracias por la Ayuda..

Re: Type "options" no hace nada?? en search de pmapper 18 Jun 2011 21:34 #602

  • m3rcury
  • OFFLINE
  • Destacad@
  • Posts: 109
  • Karma: 5
hola hola

espero que esto te ayude, blog.phpleo.com/2007/08/02/instalando-pear-en-windows/

siguiendo esta guia consegui hacerlo por primera vez en windows
recuerda estas librerias...
mdb2
mdb2_driver_pgsql
OLE
Spreadsheet_Excel_Writer

Saludos
  • Page:
  • 1
Time to create page: 0.55 seconds
 

¿Dónde nos leen?

Últimos Geo-Foros

No posts to display.

Últimos comentarios